Fixed: Android requires compiler compliance level 5.0. Please fix project properties.

When I tried to import an existing eclipse android project to my new workspace, I encountered an error:

Android requires compiler compliance level 5.0. Please fix project properties.

So here’s what I did to fix this problem:

Right Click Project > Properties > Java Build Path > Order and Export Tab > Check Your Android SDK Version on the list (I got Android 2.2)

Fixed: Android requires compiler compliance level 5.0. Please fix project properties.

Then…

Right Click Project > Properties > Java Compiler > Check Enable Project Specific Settings > Select Compiler Compliance Level
In my case, I had to changed the compiler compliance level from 1.6 to 1.5

jcompiler

And that solves my problem. :)

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *